Jump to content
explicit

Reverting Geforce Experience / Shadowplay to Version 2

Recommended Posts

Introduction

Version 3 of Geforce Experience is considered to be pretty terrible by a lot of people. Oftentimes, the Shadowplay recordings don't save, the video's FPS will drop, it will frame drop your game, etc. I have figured out how to revert it and would like to share with the community the superior version of Geforce Experience, Version 2.

How to Revert

1. If you currently have version 3 of Geforce Experience installed, go ahead and uninstall it. If you don't have it to begin with, skip this step.

2. Go ahead and install the last version of Geforce Experience V2  (2.11.4.0) from this link.

3. After installation, open the program and it will display that it is "Checking for Updates". Promptly close the program.

Disable NVIDIA from Accessing the Internet

(Firewall Method)

After closing the program go ahead and prevent any and all NVIDIA programs from accessing the internet in your firewall. Without the internet, Geforce Experience can not auto update. If you don't know how to do this god help you but it looks a bit like this... 

d82ae9a1a6f0d3ae6a81bfadabd2f880.png

Note that this may not be everything and that I may have more than you. Make sure to disable anything related to Geforce Experience / NVIDIA. Even the streaming shit. You won't use it.

Conclusion

After disabling the NVIDIA programs from the firewall you can now access the old Geforce Experience / Shadowplay.

Edited by explicit

Share this post


Link to post
11 minutes ago, explicit said:

Alphabetical order. Disable any NVIDIA / Geforce programs. I may have more than you.

screw you. your signature actually fooled me i tried to squish a bug that wasnt there

Share this post


Link to post

Kill All NVIDIA Processes and reboot PC

Go to Task Manager. In the Processes tab, find any NVIDIA related services.

Delete following NVIDIA files if existed:

  • C:\Windows\System32\DriverStore\FileRepository\nvdsp.inf file
  • C:\Windows\System32\DriverStore\FileRepository\nv_lh file
  • C:\Windows\System32\DriverStore\FileRepository\nvoclock file
  • C:\Program Files\NVIDIA Corporation\
  • C:\Program Files (x86)\NVIDIA Corporation\

Reboot the system then install the driver again. Before installing driver, first, reboot PC. Check out this article if this method does not work for you. This  answer from Tom's Hardware will help you too.

Share this post


Link to post

Just got a new asus laptop with windows 10, In the task bar(in the hidden icons area) I got the nvidia icon, when right clicking on it i get a few options; one is "open nvidia control panel" which works fine, the second is open "nvidia geforce experience" but when clicking on it nothing happens. Any ideas?

Edited by nathandev

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...